Environment variables in content pack json file fail to evaluate


(Nick) #1

Hi,

I created a content pack to add a RabbitMQ Input for graylog and I specified the login credential for RabbitMQ as following (other settings are hidden):

"broker_username":"%{RABBITMQ_DEFAULT_USER}",
"broker_password":"%{RABBITMQ_DEFAULT_PASS}",

I setup a docker container for graylog and setup the two system environment variables: RABBITMQ_DEFAULT_USER and RABBITMQ_DEFAULT_PASS
The expected behavior is that when graylog is loading the content pack, it will evaluate the two environment variables.

However, Graylog simply does not evaluate these two environment variables and then resulted in connection refused due to incorrect login credential.
Is there other way that I can make the content pack to connection to RabbitMQ without explicitly hardcoding the credential in the json file?

Thanks


(Jochen) #2

Why would you expect that?

No, that’s currently not possible.

Although we plan to revamp the Content Pack functionality in Graylog 3.0.x and might add “parameters” for content packs which would enable such usage.


(Jochen) #3

For reference:


(system) #4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.