Elasticsearch snapshot error

Hello Community, I’m trying to restore Elasticsearch backup it is showing me this error: -

{“error”:{“root_cause”:[{“type”:“illegal_state_exception”,“reason”:“Can’t get text on a FIELD_NAME at 1:1213”}],“type”:“illegal_state_exception”,“reason”:“Can’t get text on a FIELD_NAME at 1:1213”},“status”:500}ubuntu@graylog:/$ {“error”:{“root_cause”:[{}],“type”:“illegal_state_exception”,“reason”:“Can’t get text on a FIELD_NAME at 1:1213”},“status”:500}

**command I run to restore the backup

curl -XPOST http://localhost:9200/_snapshot/snapshot/2023.

**My environment
Graylog ova

  • OS Information:

anyone who can help with this error.

So your trying to restore the whole snapshot, is it possible that some of the indexes inside that snapshot are still open? I have read that causes issues.

Hey @Joel_Duffield I solved the issue.

the problem was the backup and Elasticsearch version was different.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.