# Elasticsearch:8.4.0 and graylog:5.1.1

**URL:** <https://community.graylog.org/t/elasticsearch-8-4-0-and-graylog-5-1-1/33151>\
**Category:** Graylog Central (peer support)\
**Tags:** elastic\
**Created:** [July 30, 2024, 11:09pm UTC](https://community.graylog.org/t/elasticsearch-8-4-0-and-graylog-5-1-1/33151 "2024-07-30T23:09:18Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![balarimpy](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/balarimpy/32/17024_2.png) [@balarimpy](https://community.graylog.org/u/balarimpy)\
**Post date:** [July 30, 2024, 11:09pm UTC](https://community.graylog.org/t/elasticsearch-8-4-0-and-graylog-5-1-1/33151/1 "2024-07-30T23:09:18Z")

</div>

Before you post: Your responses to these questions will help the community help you. Please complete this template if you’re asking a support question.  
**Don’t forget to select tags to help index your topic!**

**1. Describe your incident:**  
while adding the xpack.security.enabled=true for elasticsearch . i am able to connect to elasticsearch with username and password, but if I am setting username , password and host for graylog its throwing me an error below.

2024-07-30 23:07:12,922 INFO : org.graylog2.plugin.system.FilePersistedNodeIdProvider - No node ID file found. Generated: 3ca7a757-8ec4-4539-9c0c-347a051f0462  
2024-07-30 23:07:13,073 ERROR: org.graylog2.storage.versionprobe.VersionProbe - Unable to retrieve version from Elasticsearch node: Failed to connect to elasticsearch/192.168.176.2:9200. - Connection refused.  
2024-07-30 23:07:13,074 INFO : org.graylog2.storage.versionprobe.VersionProbe - Elasticsearch is not available. Retry #1  
2024-07-30 23:07:18,076 ERROR: org.graylog2.storage.versionprobe.VersionProbe - Unable to retrieve version from Elasticsearch node: Failed to connect to elasticsearch/192.168.176.2:9200. - Connection refused.  
2024-07-30 23:07:18,076 INFO : org.graylog2.storage.versionprobe.VersionProbe - Elasticsearch is not available. Retry #2  
2024-07-30 23:07:23,078 ERROR: org.graylog2.storage.versionprobe.VersionProbe - Unable to retrieve version from Elasticsearch node: Failed to connect to elasticsearch/192.168.176.2:9200. - Connection refused.  
2024-07-30 23:07:23,078 INFO : org.graylog2.storage.versionprobe.VersionProbe - Elasticsearch is not available. Retry #3  
2024-07-30 23:07:38,120 ERROR: org.graylog2.storage.versionprobe.VersionProbe - Unable to retrieve version from Elasticsearch node: Connect timed out. - Connect timed out.  
2024-07-30 23:07:

**2. Describe your environment:**

- OS Information:

- Package Version:

- Service logs, configurations, and environment variables:

**3. What steps have you already taken to try and solve the problem?**

**4. How can the community help?**

**Helpful Posting Tips:** [Tips for Posting Questions that Get Answers](https://community.graylog.org/t/tips-for-posting-questions-that-get-answers/21828) [Hold down CTRL and link on link to open tips documents in a separate tab]

---

<div class="post-metadata">

**Author:** ![gsmith](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/gsmith/32/1222_2.png) [@gsmith](https://community.graylog.org/u/gsmith)\
**Post date:** [July 31, 2024, 12:34am UTC](https://community.graylog.org/t/elasticsearch-8-4-0-and-graylog-5-1-1/33151/2 "2024-07-31T00:34:00Z")

</div>

Hey @balarimpy

> [@balarimpy](#):
>
> VersionProbe - Unable to retrieve version from Elasticsearch node: Connect timed out

Did you set up TLS?

I seen another issue here

> [@ERROR \[VersionProbe\] Unable to retrieve version from Elasticsearch node: Failed to connect to /127.0.0.1:9200. - Connection refused (Connection refused)](https://community.graylog.org/t/error-versionprobe-unable-to-retrieve-version-from-elasticsearch-node-failed-to-connect-to-127-0-0-1-9200-connection-refused-connection-refused/26912):
>
> So I have updated my graylog server from 4.2.7 to 4.3.9 yesterday. Everything was working perfectly. Today when I started the server I get a “connection refused” when trying to access the UI. I have looked at the logs and narrowed it down to this: INFO [VersionProbe] Elasticsearch is not available. Retry #1 ERROR [VersionProbe] Unable to retrieve version from Elasticsearch node: Failed to connect to /127.0.0.1:9200. - Connection refused (Connection refused). INFO [VersionProbe] Elasticsearch…

---

<div class="post-metadata">

**Author:** ![balarimpy](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/balarimpy/32/17024_2.png) [@balarimpy](https://community.graylog.org/u/balarimpy)\
**Post date:** [July 31, 2024, 3:57am UTC](https://community.graylog.org/t/elasticsearch-8-4-0-and-graylog-5-1-1/33151/3 "2024-07-31T03:57:57Z")

</div>

@gsmith No, I have just set up the xpack.security.enable=true

2024-07-31 03:55:04,972 INFO : org.graylog2.storage.versionprobe.VersionProbe - Elasticsearch is not available. Retry #101  
2024-07-31 03:55:09,977 ERROR: org.graylog2.storage.versionprobe.VersionProbe - Unable to retrieve version from Elasticsearch node elasticsearch:9200: Error response: type: security\_exception - reason: missing authentication credentials for REST request [/]  
2024-07-31 03:55:09,977 INFO : org.graylog2.storage.versionprobe.VersionProbe - Elasticsearch is not available. Retry #102  
2024-07-31 03:55:14,984 ERROR: org.graylog2.storage.versionprobe.VersionProbe - Unable to retrieve version from Elasticsearch node elasticsearch:9200: Error response: type: security\_exception - reason: missing authentication credentials for REST request [/]  
2024-07-31 03:55:14,984 INFO : org.graylog2.storage.versionprobe.VersionProbe - Elasticsearch is not available. Retry #103  
2024-07-31 03:55:19,987 ERROR: org.graylog2.storage.versionprobe.VersionProbe - Unable to retrieve version from Elasticsearch node elasticsearch:9200: Error response: type: security\_exception - reason: missing authentication credentials for REST request [/]  
2024-07-3

---

<div class="post-metadata">

**Author:** ![gsmith](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/gsmith/32/1222_2.png) [@gsmith](https://community.graylog.org/u/gsmith)\
**Post date:** [July 31, 2024, 4:25am UTC](https://community.graylog.org/t/elasticsearch-8-4-0-and-graylog-5-1-1/33151/4 "2024-07-31T04:25:59Z")

</div>

By chance does it work without

```auto
 xpack.security.enable=true ?

```

---

<div class="post-metadata">

**Author:** ![balarimpy](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/balarimpy/32/17024_2.png) [@balarimpy](https://community.graylog.org/u/balarimpy)\
**Post date:** [July 31, 2024, 4:37am UTC](https://community.graylog.org/t/elasticsearch-8-4-0-and-graylog-5-1-1/33151/5 "2024-07-31T04:37:24Z")

</div>

Yes, elasticsearch is working with configured username and password, but graylog shows above errors

---

<div class="post-metadata">

**Author:** ![gsmith](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/gsmith/32/1222_2.png) [@gsmith](https://community.graylog.org/u/gsmith)\
**Post date:** [July 31, 2024, 4:42am UTC](https://community.graylog.org/t/elasticsearch-8-4-0-and-graylog-5-1-1/33151/6 "2024-07-31T04:42:59Z")

</div>

You may want to look at the documentation [here](https://go2docs.graylog.org/5-0/downloading_and_installing_graylog/ubuntu_installation.html#:~:text=Update%20the%20following%20fields%20for%20a%20minimum%20unsecured%20running%20state%20(single%20node)%3A)

You will notice the configuration file show this:

```auto
plugins.security.disabled: true

```

Or in your case with Elasticsearch it should be

```auto
xpack.security.enable=false

```

I think that is your issue.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex016/uploads/graylog/original/3X/c/7/c7c09c6b5099570133d6502b83f50ba4430de5b6.png) [@system](https://community.graylog.org/u/system)\
**Post date:** [August 14, 2024, 4:43am UTC](https://community.graylog.org/t/elasticsearch-8-4-0-and-graylog-5-1-1/33151/7 "2024-08-14T04:43:42Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
