# Deflector exists as an index and is not an alias. Reopen

**URL:** <https://community.graylog.org/t/deflector-exists-as-an-index-and-is-not-an-alias-reopen/3463>\
**Category:** Graylog Central (peer support)\
**Created:** [December 12, 2017, 12:04pm UTC](https://community.graylog.org/t/deflector-exists-as-an-index-and-is-not-an-alias-reopen/3463 "2017-12-12T12:04:10Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![jerichoussr](https://avatars.discourse-cdn.com/v4/letter/j/7cd45c/32.png) [@jerichoussr](https://community.graylog.org/u/jerichoussr)\
**Post date:** [December 12, 2017, 12:04pm UTC](https://community.graylog.org/t/deflector-exists-as-an-index-and-is-not-an-alias-reopen/3463/1 "2017-12-12T12:04:10Z")

</div>

Hi. I have a problem with this error:

> Deflector exists as an index and is not an alias. (triggered a minute ago)  
> The deflector is meant to be an alias but exists as an index. Multiple failures of infrastructure can lead to this. Your messages are still indexed but searches and all maintenance tasks will fail or produce incorrect results. It is strongly recommend that you act as soon as possible.

I removed graylog\_deflector but i still have this error, above in log i can see this error:

> ERROR [IndexRotationThread] Couldn’t point deflector to a new index  
> org.graylog2.indexer.ElasticsearchException: Couldn’t collect aliases for index pattern graylog\_\*
> 
> {“error”:“Incorrect HTTP method for uri [/graylog\_\*/\_aliases] and method [GET], allowed: [PUT]”,“status”:405}

It happens when I start collector sidecar on my clients.  
What i have to do to resolve this problem?  
Thank you.

---

<div class="post-metadata">

**Author:** ![jochen](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/jochen/32/8_2.png) [@jochen](https://community.graylog.org/u/jochen)\
**Post date:** [December 12, 2017, 12:31pm UTC](https://community.graylog.org/t/deflector-exists-as-an-index-and-is-not-an-alias-reopen/3463/2 "2017-12-12T12:31:03Z")

</div>

> <https://github.com/Graylog2/graylog2-server/issues/4167>

---

<div class="post-metadata">

**Author:** ![jerichoussr](https://avatars.discourse-cdn.com/v4/letter/j/7cd45c/32.png) [@jerichoussr](https://community.graylog.org/u/jerichoussr)\
**Post date:** [December 13, 2017, 9:51am UTC](https://community.graylog.org/t/deflector-exists-as-an-index-and-is-not-an-alias-reopen/3463/3 "2017-12-13T09:51:42Z")

</div>

Hi, so now Graylog has a problem with new Elasticsearch?

---

<div class="post-metadata">

**Author:** ![jan](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/jan/32/11_2.png) [@jan](https://community.graylog.org/u/jan)\
**Post date:** [December 13, 2017, 9:59am UTC](https://community.graylog.org/t/deflector-exists-as-an-index-and-is-not-an-alias-reopen/3463/4 "2017-12-13T09:59:24Z")

</div>

i’m not sure how you had come to this conclusion.

Graylog does not support Elasticsearch 6 yet, be it was never announced that it works.

---

<div class="post-metadata">

**Author:** ![jerichoussr](https://avatars.discourse-cdn.com/v4/letter/j/7cd45c/32.png) [@jerichoussr](https://community.graylog.org/u/jerichoussr)\
**Post date:** [December 13, 2017, 10:32am UTC](https://community.graylog.org/t/deflector-exists-as-an-index-and-is-not-an-alias-reopen/3463/5 "2017-12-13T10:32:50Z")

</div>

It’s my big mistake. Sorry for my foolishness. Thank you very much

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex016/uploads/graylog/original/3X/c/7/c7c09c6b5099570133d6502b83f50ba4430de5b6.png) [@system](https://community.graylog.org/u/system)\
**Post date:** [December 27, 2017, 10:33am UTC](https://community.graylog.org/t/deflector-exists-as-an-index-and-is-not-an-alias-reopen/3463/6 "2017-12-27T10:33:03Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
