Create Service for OIDC integration failing without any error

Don’t forget to select tags to help index your topic!

1. Describe your incident:
I have registered graylog instance in azure as enterprise app. Trying to create service as mentioned in OIDC Configuration but clicking on “Create Service” but not bringing up any page where I can enter details as mentioned in the post.

I have checked the server logs & developer tool windows of browser but I don’t see any error. Look like clicking button has no impact at all.

2. Describe your environment:

  • OS Information:

    • Azure Kubernetes Service
    • PRETTY_NAME="Ubuntu 22.04.1 LTS" NAME="Ubuntu" VERSION_ID="22.04" VERSION="22.04.1 LTS (Jammy Jellyfish)" VERSION_CODENAME=jammy ID=ubuntu ID_LIKE=debian
    • Graylog 4.3.7+05bccc7 on XXXXXXX.svc.cluster.local (Temurin 1.8.0_345 on Linux 5.4.0-1083-azure)
  • Package Version:

  • Service logs, configurations, and environment variables:
    Configurations

node_id_file = /usr/share/graylog/data/journal/node-id
root_username = admin
root_email =
root_timezone = UTC

http_bind_address = 0.0.0.0:9000
http_external_uri = https://somedomain.com/
elasticsearch_hosts = http://somehost.svc.cluster.local:9200
allow_leading_wildcard_searches = false
allow_highlighting = false
output_batch_size = 500
output_flush_interval = 1
output_fault_count_threshold = 5
output_fault_penalty_seconds = 30
processbuffer_processors = 5
outputbuffer_processors = 3
processor_wait_strategy = blocking
ring_size = 65536
inputbuffer_ring_size = 65536
inputbuffer_processors = 2
inputbuffer_wait_strategy = blocking
message_journal_enabled = true
# Do not change `message_journal_dir` location
message_journal_dir = /usr/share/graylog/data/journal
message_journal_max_size = 5gb
lb_recognition_period_seconds = 3
# Use a replica set instead of a single host
mongodb_uri = mongodb://somemongodb.svc.cluster.local:27017/graylog?replicaSet=rs0
mongodb_max_connections = 1000
mongodb_threads_allowed_to_block_multiplier = 5
# Email transport
transport_email_enabled = false
transport_email_hostname =
transport_email_port = 2587
transport_email_use_auth = true
transport_email_use_tls = true
transport_email_use_ssl = false
transport_email_auth_username =
transport_email_auth_password =
transport_email_subject_prefix = [graylog]
transport_email_from_email =
gc_warning_threshold = 1s
transport_email_web_interface_url = https://somedomain.com
content_packs_dir = /usr/share/graylog/data/contentpacks
content_packs_auto_load = grok-patterns.json
proxied_requests_thread_pool_size = 32
prometheus_exporter_enabled = true
prometheus_exporter_bind_address = 0.0.0.0:9833

3. What steps have you already taken to try and solve the problem?
Could not do much as “Create Service” not showing any screen to enter data.

4. How can the community help?
I would like to understand what am I missing because of which button click not working.

When you installed Graylog, did you include the plugins?

sudo apt-get update && sudo apt-get install graylog-server graylog-enterprise-plugins graylog-integrations-plugins graylog-enterprise-integrations-plugins
1 Like

Checked one of the graylog node and following are the plugins installed.

I tried searched jar files for graylog-enterprise-plugins graylog-integrations-plugins graylog-enterprise-integrations-plugins plugins but I could not locate any.
As I mentioned in my question I am using helm chart to deploy cluster on Azure Kubernetes Services and I would need jar for all of these plugins. Sample plugin installation section look like below.

 plugins:
    ## If true, set proxy server to retrieve the plugins
    ##
    proxy:
      enabled: false
      host: http://your.proxy.host:8080

    locations: []
    # - name: graylog-plugin-slack-notification-4.1.1.jar
    #   url: https://github.com/KongZ/graylog-plugin-slack-notification/releases/download/v4.1.1/graylog-plugin-slack-notification-4.1.1.jar
    # - name: graylog-plugin-function-check-diff-1.0.1.jar
    #   url: https://github.com/KongZ/graylog-plugin-function-check-diff/releases/download/v1.0.1/graylog-plugin-function-check-diff-1.0.1.jar
    # - name: graylog-plugin-google-cloud-pubsub-1.0.4.jar
    #   url: https://github.com/KongZ/graylog-plugin-google-cloud-pubsub/releases/download/v1.0.4/graylog-plugin-google-cloud-pubsub-1.0.4.jar
    # - name: graylog-plugin-auth-sso-3.3.0.jar
    #   url: https://github.com/Graylog2/graylog-plugin-auth-sso/releases/download/3.3.0/graylog-plugin-auth-sso-3.3.0.jar

Question is from where I can get jar for these plugins?

Hello @RahulMahulkar

Just chiming, I noticed your using Azure Kubernetes /Helm. Im unfamialr with those BUT as for docker images I pull mine from here not sure if you can use those.

https://hub.docker.com/u/graylog

As for a installation I normally run these commands to get all the plugins

Ubuntu:

sudo apt-get update && sudo apt-get install graylog-server graylog-enterprise-plugins graylog-integrations-plugins graylog-enterprise-integrations-plugins

Red Hat repo

yum install graylog-server graylog-enterprise-plugins graylog-integrations-plugins graylog-enterprise-integrations-plugins

EDIT if all else fails you can grab them from GitHub, just an idea

Hope that helps

Thank you for chiming in. As I said, I am using AKS and helm chart so I would need plugins in jar form. I can not install the way you have suggested. I am using Docker Hub image from my helm chart.

Finally managed to solve the problem. Thank you @tmacgbay for letting me know which plugins are required. Without your help it was impossible. Thank you @gsmith too!!!

Following is what I have done.

Updated plugin section as below in values.yaml and redeploy helm chart.

    ## Additional plugins you need to install on Graylog.    
    plugins:
      ## If true, set proxy server to retrieve the plugins
      ##
      proxy:
        enabled: false
        host: http://your.proxy.host:8080

      locations: 
      - name: graylog-enterprise-plugins-4.3.7.tgz
        url: https://packages.graylog2.org/releases/graylog-enterprise/graylog-enterprise-plugins-4.3.7.tgz
      - name: graylog-integrations-plugins-4.3.7.tgz
        url: https://packages.graylog2.org/releases/graylog-integrations/graylog-integrations-plugins-4.3.7.tgz
      - name: graylog-enterprise-integrations-plugins-4.3.7.tgz
        url: https://packages.graylog2.org/releases/graylog-enterprise-integrations/graylog-enterprise-integrations-plugins-4.3.7.tgz

I can now see OIDC option in services which was not there earlier.

And big discovery. This is enterprise feature which requires license. :slight_smile:

1 Like

Great!! Thanks for posting up how you did it too… mark it as the solution for future searchers!

You can sign up for a free Enterprise License at Graylog which will work as long as you keep your data below 2GB a day.

I am guessing if you are putting it together with Helm Chart you will go over that… the purchased version have even better support :stuck_out_tongue: (But not by much… haha)

1 Like