Copy Message/ID broken in v6+?

Anyone know how to “copy message” or “copy id” in GrayLog 6+?
The buttons used to work in v5.2.8, but in v6 and up, the button locations changed, and do nothing when pressed.

I’m trying to test some pipeline rules, and can’t get my message in there…

Mine works?

image

Graylog 6.0.3+eb761c5 on dfd87377a88a (Eclipse Adoptium 17.0.11 on Linux 5.15.0-94-generic)

I don’t get the “Copied!” box when I press the buttons. I tried on Firefox, Edge, Chrome, tried all GrayLog 6 versions, same thing. I press the button, and nothing is in the clipboard.

With GrayLog 5.2, it works

Looks like it may be browser-specific. Which browser are you using? Can you reproduce it in another browser?

In other words, it does not work / copy the text in any browser.

Hi All, shoutout to our rick who figured out this is related to the copy api only working via HTTPS. We’ve opened an issue via Copy functionality (Copy message, copy id, copy token, copy scratchpad) does not work over http but does work over https · Issue #19643 · Graylog2/graylog2-server · GitHub to track this.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.