Cannot create new Indices or append messages after upgrade to 2.2.3 from 2.2.2


(Andy Hughes) #1

I have tried this twice now, but had to revert back to snap shots

After the upgrade from 2,2,3 , the server starts up ok, but when a new indice is required a error appears in the graylog server.log , reported by java saying that it cant create a new indice.

I don’t have a copy of the logs as had to revert to snapshot however here is all the facts I have available

the server.conf wasn’t replaced during upgrade, it created one called server.conf.rpm.new however when it happened , I copied over the sha keys, to the file and swapped them over.

my build (centos7, java 1,8, elasticsearch 2.3.3, MongoD v3.2.12),

I did notice in the new Graylog server.conf there appears to be a lot more elasticsearch settings

However I noticed missing the reference to the elasticsearch.yml location
also no mention of the cluster name

I assumed this was deliberate, so didn’t put these lines in (I think I tried on the first occasion this happened and Graylog wouldn’t start up, so all I put in was the KEY)

I checked that the indices where owned by elasticsearch
I tried to touch the new indice to see if manually creating it would allow it to work, but same error saying cant create

Up until the point when the indice needed a new one creating and a rotation taking place, graylog was running fine.

Diskspace is 65%, I even deleted a couple of indices from the GUI, but no joy.

I cycled the deflector.

Nothing would would create a new indice, and no new messages were being appended after it hit this problem.


(Jochen) #2

Please post the exact error message from the logs and your Elasticsearch and Graylog configuration files.


(Andy Hughes) #3

Please notice from my original post that this isn’t possible


(Jochen) #4

In this case it’s unfortunately impossible to analyze the problem you’ve encountered.

FWIW, numerous users have upgraded from Graylog 2.2.2 to Graylog 2.2.3 without any problems, so you might want to try it again and keep the relevant information in case that problems arise.


(Andy Hughes) #5

Thank you for your positivity, I think Ill just wait and hope for a better upgrader on 2.2.4 maybe


(Andy Hughes) #6

Could you maybe confirm that my observations and method of copying just the SHA key across would be all I needed to do

“However I noticed missing the reference to the elasticsearch.yml location
also no mention of the cluster name”??


(Jochen) #7

No, I don’t know your configuration.

There won’t be another release in the Graylog 2.2.x series unless a critical bug is discovered.


(Andy Hughes) #8

so you cant confirm if there should be a link to the elasticsearch.yml file in the new conf even though its a standard setting in 2.2.2 that needed completing ,

or that you don’t need to add the elasticsearch cluster name into the extra elastic search section in the same graylog conf file

, both of which are missing as sections that were sections in the old greylog server conf / elasticsearch.xml files ?


(Jochen) #9

Please refer to the annotated configuration file for information about each setting:


(Andy Hughes) #10

Can someone else shed any light ?, this guy seems to think he is being helpful with these types of responses


(Jochen) #11

You’ve been given the link to the annotated configuration file with an explanation of each configuration setting.

Since you didn’t share any useful information about your setup or your problem, that’s all you can expect.

This guy” is now keeping away from this discussion topic. Good luck!


(Andy Hughes) #12

I have provided you everything other than a log. Perhaps someone else has had a similar issue and remembers the cause. Perhaps someone else may have additional knowledge or seen similar behaviors that you have not. I see you have been on the project 6 months , I also work for a software house , however there would never be an excuse for speaking to a customer like you seem to think is acceptable. I have worked for 4 company’s that I have implemented Graylog , 2 enterprise and 2 free , I patched a live environment that people use , and I was up against getting them working again and I reverted to snapshot before taking a copy of the log. That doesn’t justify your stinking attitude.


(Andy Hughes) #13

This was caused by me setting the repository for 2,3 I believe as I didn’t do a clean all when i attempted to use 2.2.x repository and it wouldn’t upgrade, was unfortunate that this repository existed :slight_smile:


(system) #14

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.