Blank Page accessing Graylog Using Ubuntu 22.04 and have Nginx

1. Describe your incident:
I cannot access Graylog dashboard, its appear as a blank page with error like this:
Refused to execute script from ‘’ because its MIME type (‘text/html’) is not executable, and strict MIME type checking is enabled.

This server has a Grafana in it, which is the main page of url is grafana dashboard, and i route the graylog to the: My grafana is werk well.

Grafana and Graylog are running behind the nginx and i have configured it too.

I try to curl localhost:9000 (which is where graylog runs), it work well, but in browser is a blank page.

I try running graylog as a alone in another server without the grafana or nginx, its work well too.

This is my environment:
OS: Ubuntu 22.04
Nginx: 1.18.0
Opensearch: 2.8.0
Graylog: 5.1

server.conf in graylog was:

http_external_uri =
http_enable_cors = true
http_publish_uri = http://publicIP:9000/
http_bind_address =
trusted_proxies =, 0:0:0:0:0:0:0:1/128

my opensearch.yml
transport.tcp.port: 9300
http.port: 9200 true

I have tried this step:

  1. add this into my nginx.conf
location ~ \.js$ {
    add_header Content-Type application/javascript;

but it doesnt work. Anyone could help me?

Can you share your nginx config for graylog? Also, are you able to reach graylog directly (not behind nginx)?

In case you haven’t run across it already, here is a link to configuring nginx to work with the graylog web interface: Overview

i have changed it to, but still same:

    location /graylog/ {
    	proxy_pass http://localhost:9000; #Graylog is running on port 9000
	proxy_set_header Host $host;
        # proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        # proxy_set_header X-Forwarded-Proto $scheme;
	proxy_set_header X-Graylog-Server-URL https://$server_name/graylog/;

thankyou, it worked well. i have add the following line:

rewrite          ^/graylog/(.*)$  /$1  break;
1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.