Beat Input with TLS and Filebeat 5.4.0


#1

Hello,
i am using graylog 2.2.3, sidecar collector 0.1.1 and filebeat 5.4.0. If i create a beat input with tls communication and sidecar read the configuration from the graylog server and create a filebeat config file, in the config file is a tls section with the certificate name and so on. But filebeat don’t use a secure communication and sends message with http and not https. I think, in the configuration file for file beat must be a ssl section, not a tls section. If i create a snippet with ssl section as described in the file beat documentation, the communication works with https.

It is a bug, that a tls section is created?

Thanks
Winschi


(Jochen) #2

The name of the configuration section for TLS in the Beats platform changed from tls to ssl with Beats 5.0, see https://www.elastic.co/guide/en/beats/libbeat/master/breaking-changes-5.0.html#_configuration_file_changes.

Graylog Collector Sidecar 0.1.0 and higher supports Beats 5.x, so it should use the correct settings.

Feel free to create a bug report at https://github.com/Graylog2/collector-sidecar/issues


(system) #3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.