# AWS Integration - Kinesis/CloudWatch - Configuration error

**URL:** <https://community.graylog.org/t/aws-integration-kinesis-cloudwatch-configuration-error/16263>\
**Category:** Graylog Central (peer support)\
**Created:** [July 9, 2020, 7:00am UTC](https://community.graylog.org/t/aws-integration-kinesis-cloudwatch-configuration-error/16263 "2020-07-09T07:00:34Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![v\_2nas](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/v_2nas/32/268_2.png) [@v\_2nas](https://community.graylog.org/u/v_2nas)\
**Post date:** [July 9, 2020, 7:00am UTC](https://community.graylog.org/t/aws-integration-kinesis-cloudwatch-configuration-error/16263/1 "2020-07-09T07:00:34Z")

</div>

Hi All,

I am running graylog 3.3.1. I am trying to configure AWS Kinesis/CloudWatch input however I get error when configuring it. I have created the AWS user, role, and created required policies.

However, when i select aws authentication type as key & secret or automatic (environment variable created). I get the following error. I have also tried automatic authentication with environment variable but the error remains. appreciate your direction in resolving this issue.

> software.amazon.awssdk.core.exception.SdkClientException: Unable to load credentials from any of the providers in the chain AwsCredentialsProviderChain(credentialsPr  
> oviders=[SystemPropertyCredentialsProvider(), EnvironmentVariableCredentialsProvider(), WebIdentityTokenCredentialsProvider(), ProfileCredentialsProvider(), Containe  
> rCredentialsProvider(), InstanceProfileCredentialsProvider()]) : [SystemPropertyCredentialsProvider(): Unable to load credentials from system settings. Access key mu  
> st be specified either via environment variable (AWS\_ACCESS\_KEY\_ID) or system property (aws.accessKeyId)., EnvironmentVariableCredentialsProvider(): Unable to load c  
> redentials from system settings. Access key must be specified either via environment variable (AWS\_ACCESS\_KEY\_ID) or system property (aws.accessKeyId)., WebIdentityT  
> okenCredentialsProvider(): Either the environment variable AWS\_WEB\_IDENTITY\_TOKEN\_FILE or the javaproperty aws.webIdentityTokenFile must be set., ProfileCredentialsP  
> rovider(): Profile file contained no credentials for profile ‘default’: ProfileFile(profiles=), ContainerCredentialsProvider(): Cannot fetch credentials from conta  
> iner - neither AWS\_CONTAINER\_CREDENTIALS\_FULL\_URI or AWS\_CONTAINER\_CREDENTIALS\_RELATIVE\_URI environment variables are set., InstanceProfileCredentialsProvider(): The  
> requested metadata is not found at [http://169.254.169.254/latest/meta-data/iam/security](http://169.254.169.254/latest/meta-data/iam/security)

---

<div class="post-metadata">

**Author:** ![v\_2nas](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/v_2nas/32/268_2.png) [@v\_2nas](https://community.graylog.org/u/v_2nas)\
**Post date:** [July 15, 2020, 10:49am UTC](https://community.graylog.org/t/aws-integration-kinesis-cloudwatch-configuration-error/16263/2 "2020-07-15T10:49:30Z")

</div>

Bringing to the attention of graylog community for their direction towards the resolution.

---

<div class="post-metadata">

**Author:** ![lingpri](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/lingpri/32/5730_2.png) [@lingpri](https://community.graylog.org/u/lingpri)\
**Post date:** [July 17, 2020, 3:01pm UTC](https://community.graylog.org/t/aws-integration-kinesis-cloudwatch-configuration-error/16263/3 "2020-07-17T15:01:51Z")

</div>

Hello - Please try [aws-cli](https://aws.amazon.com/cli/) and see if you are able to connect with this.

---

<div class="post-metadata">

**Author:** ![v\_2nas](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/v_2nas/32/268_2.png) [@v\_2nas](https://community.graylog.org/u/v_2nas)\
**Post date:** [July 20, 2020, 7:35am UTC](https://community.graylog.org/t/aws-integration-kinesis-cloudwatch-configuration-error/16263/4 "2020-07-20T07:35:40Z")

</div>

@lingpri, you mean defining the credentials via aws cli configure command? if so, i have done that, and changed the authentication to automatic. It didn’t work.

---

<div class="post-metadata">

**Author:** ![lingpri](https://sea2.discourse-cdn.com/flex016/user_avatar/community.graylog.org/lingpri/32/5730_2.png) [@lingpri](https://community.graylog.org/u/lingpri)\
**Post date:** [July 20, 2020, 8:18pm UTC](https://community.graylog.org/t/aws-integration-kinesis-cloudwatch-configuration-error/16263/5 "2020-07-20T20:18:29Z")

</div>

step1 : pwd (/home/user/.aws)  
step2: there’s a file named `credentials`  
step3:contents of the file is as below,

```auto
[default]
aws_access_key_id = <your value>
aws_secret_access_key = <your secret access key>

```

`AWS Integrations` is working fine for me in my local. Please retry.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex016/uploads/graylog/original/3X/c/7/c7c09c6b5099570133d6502b83f50ba4430de5b6.png) [@system](https://community.graylog.org/u/system)\
**Post date:** [August 3, 2020, 8:18pm UTC](https://community.graylog.org/t/aws-integration-kinesis-cloudwatch-configuration-error/16263/6 "2020-08-03T20:18:36Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
